Опубликован: 06.12.2011 | Уровень: для всех | Доступ: платный
Лекция 8:

Проведение расходного документа, журналы документов, программная работа с документами

< Лекция 7 || Лекция 8: 12345 || Лекция 9 >

Отчет – приход и расход материалов

Мы собираемся построить отчет, который выводил бы сведения о начальном и конечном остатке материалов за определенный временной интервал, а так же – сведения о приходе и расходе материалов за этот период.

Создадим новый отчет, назовем его Материалы, включим в подсистему ОперативныйУчетМатериалов, добавим основную схему компоновки данных, создадим новый набор данных – Запрос. В конструкторе запроса выберем из виртуальной таблицы регистра накопления ОстаткиМатериалов следующие поля, рис. 7.6.:

  • Номенклатура
  • ОтветственныйСотрудник
  • КоличествоНачальныйОстаток
  • КоличествоПриход
  • КоличествоРасход
  • КоличествоКонечныйОстаток
Настройка запроса для отчета

увеличить изображение
Рис. 7.6. Настройка запроса для отчета

Нажмем ОК в окне конструктора запроса, перейдем на закладку Ресурсы окна редактора СКД, добавим все количественные поля в состав ресурсов, рис. 7.7.

Настройка состава ресурсов

увеличить изображение
Рис. 7.7. Настройка состава ресурсов

На закладке Настройки воспользуемся конструктором настроек. Выберем табличный тип отчета, нажмем Далее, в окне настройки состава и порядка следования полей, которые будут отображаться в отчете, расположим поля следующим образом:

  • Номенклатура
  • ОтветственныйСотрудник
  • КоличествоНачальныйОстаток
  • КоличестоПриход
  • КоличествоРасход
  • КоличествоКонечныйОстаток

На следующем этапе укажем, что группировка строк будет осуществляться по полю Номенклатура, колонок – по полю ОтветственныйСотрудник.

На этапе настройки упорядочения укажем упорядочение по возрастанию по полю Номенклатура.

На этом настройка таблицы завершена.

На верхнем уровне настроек отчета укажем, что параметры Начало периода и Конец периода следует включать в пользовательские настройки.

Отчет готов, нам осталось лишь проверить его работу в режиме 1С:Предприятие, рис. 7.8.

Готовый отчет

увеличить изображение
Рис. 7.8. Готовый отчет

В нашей конфигурации есть пара документов, относящихся к одной сфере деятельности – к учету материалов. Выше мы упоминали об объекте Журнал документов. Познакомимся с этим объектом поближе.

Журнал документов

Добавим в конфигурацию новый журнал документов, назовем его ДокументыУчетаМатериалов. Включим журнал в подсистему ОперативныйУчетМатериалов.

На вкладке Данные добавим в состав документов, регистрируемых в журнале, документы ПоступлениеМатериалов и ОтпускМатериаловМастеру. Добавим в журнал графу с именем ОтветственныйСотрудник, заполним свойство Ссылки для этой графы, указав реквизиты ОтветственныйСотрудник из включенных в журнал документов, рис. 7.9.

Настройка журнала документов

увеличить изображение
Рис. 7.9. Настройка журнала документов

В режиме 1С:Предприятие наш журнал позволит просматривать список документов разных типов, включенных в него, рис. 7.10.

Журнал документов в режиме 1С:Предприятие

увеличить изображение
Рис. 7.10. Журнал документов в режиме 1С:Предприятие
< Лекция 7 || Лекция 8: 12345 || Лекция 9 >
Лариса Дятчина
Лариса Дятчина

Код 

&НаКлиенте

Процедура ОсновноеКонтактноеЛицоПриИзменении(Элемент)

Если НЕ ПроверитьЗаполнениеРеквизита() Тогда

 Сообщить("Выбранное контактное лицо, "+Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента.");

КонецЕсли;

КонецПроцедуры

 

&НаСервере

Функция ПроверитьЗаполнениеРеквизита()

 Возврат (Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);  

КонецФункции

&НаСервере

Процедура УстановитьНомерПредставителя()

 

 Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения;

КонецПроцедуры

При проверке выдает ошибку:

{Справочник.Контрагенты.Форма.ФормаСписка.Форма(12,11)}: Переменная не определена (Объект)
 Возврат (<<?>>Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);   (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,2)}: Переменная не определена (Объект)
 <<?>>Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,32)}: Переменная не определена (Объект)
 Объект.ТелефонКонтактногоЛица=<<?>>Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(6,41)}: Переменная не определена (Объект)
 Сообщить("Выбранное контактное лицо, "+<<?>>Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента."); (Проверка: Тонкий клиент)

 

работаю на версии 1С:Предприятие 8.3 (8.3.10.2650)

максим матасов
максим матасов
Леонид Альбрехт
Леонид Альбрехт
Россия, Екатеринбург, 10, 2004
Оксана Максимова
Оксана Максимова
Россия, Екатеринбург, Уральский государственный университет им. А. М. Горького, 2013