Опубликован: 06.12.2011 | Уровень: для всех | Доступ: платный
Лекция 9:

Оборотные регистры накопления, последовательности, нумераторы, регистры сведений

Отчет о продажах по контрагентам

Создадим новый отчет, дадим ему имя ПродажиПоКонтрагентам, добавим его в подсистему ОперативныйУчетМатериалов.

Откроем основную схему компоновки данных отчета. Добавим новый набор данных – Запрос. Создадим с помощью конструктора запроса запрос следующего содержания, рис. 8.8.

Набор данных в конструкторе СКД

увеличить изображение
Рис. 8.8. Набор данных в конструкторе СКД

Мы выбираем из виртуальной таблицы ПродажиОбороты данные о контрагенте, о количестве проданных материалов и получаем показатель прибыли

На закладке Ресурсы мы указываем, что поле Прибыль является ресурсом, применяем к нему функцию Сумма, рис. 8.9.

Выбор ресурсов в конструкторе СКД

увеличить изображение
Рис. 8.9. Выбор ресурсов в конструкторе СКД

На вкладке Настройки мы включим отображение параметров Начало периода и Конец периода в пользовательском интерфейсе и, вызывав конструктор настроек компоновки данных, выберем тип отчета – Список, в качестве полей, которые будут отображаться в отчете, выберем Контрагент, Номенклатура и Прибыль, рис. 8.10.

Выбор полей отчета при представлении отчета в виде списка

Рис. 8.10. Выбор полей отчета при представлении отчета в виде списка

В следующем окне в качестве полей, по которым будет производиться группировка данных, выберем Контрагент и Номенклатура.

В качестве поля для упорядочивания, в следующем окне конструктора, выберем поле Контрагент, упорядочивать будем по возрастанию. После этого нажмем ОК и вкладка Настройки окна конструктора СКД приобретет такой вид, рис. 8.11.

Вкладка Настройки окна конструктора СКД

увеличить изображение
Рис. 8.11. Вкладка Настройки окна конструктора СКД

На рис. 8.12. представлены результаты работы отчета в пользовательском режиме.

Отчет Продажи по контрагентам

Рис. 8.12. Отчет Продажи по контрагентам

Команда вызова формы регистра в форме документа

Доработаем форму документа РеализацияМатериалов. Документ проводится по двум регистрам накопления – по регистру Продажи и по регистру ОстаткиМатериалов. Удобно было бы иметь возможность прямо из документа перейти в окно регистра и просмотреть его содержимое после проведения документа. Для того, чтобы реализовать это, нам понадобится закладка Глобальные команды закладки Команды окна редактора форм. Все, что нужно для размещения на командной панели формы дополнительных кнопок, ведущих к регистрам – перетащить нужную команду на панель, рис. 8.13.

Кнопки перехода в регистры накопления на командной панели формы

увеличить изображение
Рис. 8.13. Кнопки перехода в регистры накопления на командной панели формы
Лариса Дятчина
Лариса Дятчина

Код 

&НаКлиенте

Процедура ОсновноеКонтактноеЛицоПриИзменении(Элемент)

Если НЕ ПроверитьЗаполнениеРеквизита() Тогда

 Сообщить("Выбранное контактное лицо, "+Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента.");

КонецЕсли;

КонецПроцедуры

 

&НаСервере

Функция ПроверитьЗаполнениеРеквизита()

 Возврат (Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);  

КонецФункции

&НаСервере

Процедура УстановитьНомерПредставителя()

 

 Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения;

КонецПроцедуры

При проверке выдает ошибку:

{Справочник.Контрагенты.Форма.ФормаСписка.Форма(12,11)}: Переменная не определена (Объект)
 Возврат (<<?>>Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);   (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,2)}: Переменная не определена (Объект)
 <<?>>Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,32)}: Переменная не определена (Объект)
 Объект.ТелефонКонтактногоЛица=<<?>>Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(6,41)}: Переменная не определена (Объект)
 Сообщить("Выбранное контактное лицо, "+<<?>>Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента."); (Проверка: Тонкий клиент)

 

работаю на версии 1С:Предприятие 8.3 (8.3.10.2650)

максим матасов
максим матасов
Леонид Альбрехт
Леонид Альбрехт
Россия, Екатеринбург, 10, 2004
Оксана Максимова
Оксана Максимова
Россия, Екатеринбург, Уральский государственный университет им. А. М. Горького, 2013