Опубликован: 06.12.2011 | Уровень: для всех | Доступ: платный
Лекция 4:

Справочники, разработка форм

< Лекция 3 || Лекция 4: 123456 || Лекция 5 >

Разработка формы справочника ФизическиеЛица

Откроем закладку Формы окна редактирования справочника ФизическиеЛица. Можно отметить, рис. 3.11, что ни одной формы не задано – то есть все они создаются системой автоматически. Нам же нужна собственная форма элемента справочника.

Вкладка Формы окна редактирования объекта

Рис. 3.11. Вкладка Формы окна редактирования объекта

Нажмем на кнопку с увеличительным стеклом напротив поля Элемента в группе Формы. Появится окно Конструктора формы справочника, в его первом окне оставим все по умолчанию – а именно – нас интересует Форма элемента справочника, рис. 3.12.

Первое окно конструктора форм справочника

Рис. 3.12. Первое окно конструктора форм справочника

В следующем окне, рис. 3.13., мы можем указать состав реквизитов для расположения на форме, а так же указать количество колонок, которое нужно для расположения элементов управления на форме. Оставим здесь все так же по умолчанию и нажмем на кнопку Готово.

Второе окно конструктора форм справочника

Рис. 3.13. Второе окно конструктора форм справочника

После этого нужно открыть окно редактора форм для формы элемента справочника, рис. 3.14. Ранее мы уже сталкивались с этим окном, теперь рассмотрим его подробнее.

Окно редактирования формы элемента справочника

увеличить изображение
Рис. 3.14. Окно редактирования формы элемента справочника

На самом деле, это окно объединяет в себе несколько редакторов и окон. В частности, это следующие:

Редактор элементов формы (закладка Элементы в верхней левой части окна) – с его помощью можно контролировать элементы управления, которые будут расположены на форме. Выделив элемент в данном окне, мы можем настраивать его свойства в стандартной палитре свойств. Обратите внимание на кнопку Проверить, находящуюся в правой части командной панели закладки Элементы. Нажатие на нее приводит к выводу конструируемой формы в интерактивном виде, что позволяет лучше оценить ее внешний вид в пользовательском режиме, но, конечно, не дает возможности работать с данными информационной базы.

Окно просмотра формы (закладка Форма в нижней части окна) – здесь представлена форма в том виде, который она примет после настроек. Кроме того, выделяя элементы формы в данном окне, мы, не имея возможности, как это было ранее, произвольно перемещать их, можем вызывать их контекстное меню, рис. 3.14., с помощью которого можно перемещать элемент вверх или вниз (то же самое можно делать в окне Элементы), открывать окно его свойств, назначать обработчики событий (их можно назначать и в окне Свойства, открытом для данного элемента).

Работа с элементами формы

увеличить изображение
Рис. 3.15. Работа с элементами формы

Редактор реквизитов представлен вкладкой Реквизиты ( рис. 3.15.). Для того, чтобы добавить реквизит объекта на форму (то есть – создать элемент управления, связанный с данным реквизитом), достаточно перетащить элемент из окна Реквизиты в окно Элементы. Реквизиты, уже присутствующие на форме, отмечены серым квадратиком.

Редактор команд можно открыть, нажав на вкладку Команды. Здесь доступны три дополнительные вкладки. Вкладка Команды формы (по умолчанию пустая) содержит команды формы, их можно сравнить с командными кнопками, которые в версии 1С:Предприятие 8.1. можно было размещать на форме. Теперь последовательность действий выглядит так – сначала создать команду формы, потом перетащить ее в окно Элементы, настроить свойства, задать обработчики событий. Вкладка Стандартные команды ( рис. 3.16.) содержит стандартный набор команд – в нашем случае – стандартный для формы и табличного поля, размещенного на форме.

Стандартные команды

увеличить изображение
Рис. 3.16. Стандартные команды

Вкладка Глобальные команды содержит набор команд уровня прикладного решения.

Вкладка Параметры предоставляет доступ к редактору параметров.

Вкладка Командный интерфейс позволяет редактировать командный интерфейс.

Реализуем автоматическое заполнение поля Наименование на основе полей Фамилия, Имя и Отчество.

Для этого сначала настроим элемент управления, отображающий наименование на форме, таким образом, чтобы его нельзя было редактировать. Выделим элемент управления в панели Элементы, откроем окно его свойств и установим свойство ТолькоПросмотр, рис. 3.17.. Благодаря этому свойству пользователь не сможет отредактировать текст в поле ввода. Похожего эффекта можно достичь и другими способами, например, указав в свойстве Вид элемента элемента Наименование вместо Поле вводаПоле надписи.

Настройка элемента Наименование

увеличить изображение
Рис. 3.17. Настройка элемента Наименование

Для правильного формирования наименования важно, чтобы пользователь ввел данные в поля Фамилия, Имя и Отчество.

< Лекция 3 || Лекция 4: 123456 || Лекция 5 >
Лариса Дятчина
Лариса Дятчина

Код 

&НаКлиенте

Процедура ОсновноеКонтактноеЛицоПриИзменении(Элемент)

Если НЕ ПроверитьЗаполнениеРеквизита() Тогда

 Сообщить("Выбранное контактное лицо, "+Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента.");

КонецЕсли;

КонецПроцедуры

 

&НаСервере

Функция ПроверитьЗаполнениеРеквизита()

 Возврат (Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);  

КонецФункции

&НаСервере

Процедура УстановитьНомерПредставителя()

 

 Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения;

КонецПроцедуры

При проверке выдает ошибку:

{Справочник.Контрагенты.Форма.ФормаСписка.Форма(12,11)}: Переменная не определена (Объект)
 Возврат (<<?>>Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);   (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,2)}: Переменная не определена (Объект)
 <<?>>Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,32)}: Переменная не определена (Объект)
 Объект.ТелефонКонтактногоЛица=<<?>>Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(6,41)}: Переменная не определена (Объект)
 Сообщить("Выбранное контактное лицо, "+<<?>>Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента."); (Проверка: Тонкий клиент)

 

работаю на версии 1С:Предприятие 8.3 (8.3.10.2650)

максим матасов
максим матасов
Леонид Альбрехт
Леонид Альбрехт
Россия, Екатеринбург, 10, 2004
Оксана Максимова
Оксана Максимова
Россия, Екатеринбург, Уральский государственный университет им. А. М. Горького, 2013