Опубликован: 06.12.2011 | Уровень: для всех | Доступ: платный
Лекция 3:

Константы, основы клиент-серверного программирования, общие реквизиты

< Лекция 2 || Лекция 3: 12345 || Лекция 4 >

Форма констант

Для создания формы констант нужно вызвать контекстное меню ветви Константы дерева конфигурации и выбрать в нем команду Создать форму констант. В появившемся окне Конструктор общих форм, рис. 2.8., нужно оставить тип формы в значении Форма констант, при необходимости заполнить другие поля и нажать на кнопку Далее.

Конструктор общих форм

Рис. 2.8. Конструктор общих форм

В появившемся окне, рис. 2.9. можно настроить состав формы констант, в нашем случае нас устраивает то, что в нее включены обе созданные в конфигурации константы, поэтому нажмем на кнопку Готово.

Конструктор общих форм, состав формы констант

Рис. 2.9. Конструктор общих форм, состав формы констант

В ветви Общие формы появится новая форма с именем ФормаКонстант, будет открыто окно редактирования формы, рис. 2.10.

Окно редактирования формы

Рис. 2.10. Окно редактирования формы

При разработке командного интерфейса в 1С:Предприятие 8.2. используется концепция декларативного описания. Это означает, что разработчик задает схематичное описание элементов интерфейса, их группировку, свойства. При построении интерфейса для конкретного пользователя система создает его, опираясь на описание, сделанное разработчиком, учитывая различные дополнительные факторы, например, такие как права пользователя и пользовательские настройки интерфейса.

Форму констант так же нужно включить в одну из подсистем. Включим ее в подсистему Администрирование, посмотрим, что у нас получилось, рис. 2.11.

Окно редактирования формы

Рис. 2.11. Окно редактирования формы

Мы видим, что форма констант доступна в группе Сервис панели действий раздела Администрирование. В текущей ситуации наличие в той же группе команды вызова окна константы Префикс номера может показаться избыточным. Для того чтобы убрать эту команду из панели действий, нам понадобится отредактировать командный интерфейс. Для этого мы можем выполнить команду Открыть командный интерфейс подсистемы Администрирование и в появившемся окне, рис. 2.12., снять флаг Видимость для команды Префикс номера группы Сервис панели действий.

Настройка панели действий

Рис. 2.12. Настройка панели действий
< Лекция 2 || Лекция 3: 12345 || Лекция 4 >
Лариса Дятчина
Лариса Дятчина

Код 

&НаКлиенте

Процедура ОсновноеКонтактноеЛицоПриИзменении(Элемент)

Если НЕ ПроверитьЗаполнениеРеквизита() Тогда

 Сообщить("Выбранное контактное лицо, "+Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента.");

КонецЕсли;

КонецПроцедуры

 

&НаСервере

Функция ПроверитьЗаполнениеРеквизита()

 Возврат (Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);  

КонецФункции

&НаСервере

Процедура УстановитьНомерПредставителя()

 

 Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения;

КонецПроцедуры

При проверке выдает ошибку:

{Справочник.Контрагенты.Форма.ФормаСписка.Форма(12,11)}: Переменная не определена (Объект)
 Возврат (<<?>>Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);   (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,2)}: Переменная не определена (Объект)
 <<?>>Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,32)}: Переменная не определена (Объект)
 Объект.ТелефонКонтактногоЛица=<<?>>Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(6,41)}: Переменная не определена (Объект)
 Сообщить("Выбранное контактное лицо, "+<<?>>Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента."); (Проверка: Тонкий клиент)

 

работаю на версии 1С:Предприятие 8.3 (8.3.10.2650)

максим матасов
максим матасов
Леонид Альбрехт
Леонид Альбрехт
Россия, Екатеринбург, 10, 2004
Оксана Максимова
Оксана Максимова
Россия, Екатеринбург, Уральский государственный университет им. А. М. Горького, 2013