Опубликован: 06.12.2011 | Уровень: для всех | Доступ: платный
Лекция 2:

Начало разработки

< Лекция 1 || Лекция 2: 12345 || Лекция 3 >

Пользователи, роли и панель разделов

Для демонстрации настройки видимости подсистем по ролям нам понадобятся два пользователя и две роли. Сначала создадим две роли – Администратор и Сотрудник. В дереве конфигурации перейдем в ветвь Общие > Роли, создадим новую роль, дадим ей имя Администратор. Отметим права на доступ ко всем объектам (можно выполнить команду Действия > Установить все права), установим флажок Устанавливать права для новых объектов, рис. 1.20 Тем самым, при создании новых объектов, права на выполнение различных действий с ними будут добавляться к роли автоматически.

Настройка роли Администратор

увеличить изображение
Рис. 1.20. Настройка роли Администратор

Вторая роль, которая нас сейчас интересует, отличается от только что созданной названием – назовем ее Сотрудник, и тем, что у нее отключено право Администрирование у корневого объекта конфигурации. В свое время мы уделим настройке прав доступа к объектам больше внимания, сейчас сосредоточимся на настройках видимости закладок панели разделов.

Выполним уже знакомую вам команду контекстного меню корневого элемента дерева конфигурации Открыть командный интерфейс конфигурации, в окне Командный интерфейс снимем флаг напротив раздела Администрирование у роли Сотрудник, остальные флаги должны быть установлены, рис. 1.21.

Настройка видимости разделов по ролям

Рис. 1.21. Настройка видимости разделов по ролям

Создадим двух пользователей конфигурации. В Конфигураторе выполним команду Администрирование > Пользователи, в появившемся окне Список пользователей нажмем на кнопку Добавить. На вкладке Основные окна Пользователь дадим первому пользователю имя Администратор, реквизит Полное имя будет заполнен автоматически.

Остальные параметры оставим в значении по умолчанию, что приведет к тому, что у пользователя будет пустой пароль и он будет отображаться в списке выбора пользователей ( рис. 1.22.), хотя, в целях безопасности, пользователя с административными правами можно скрыть из списка выбора, да и имя "Администратор" лучше заменить на что-нибудь менее очевидное.

Создание нового пользователя

Рис. 1.22. Создание нового пользователя

Перейдем на вкладку Прочие и в списке Доступные роли установим роль Администратор, рис. 1.23.

Настройка доступных ролей

Рис. 1.23. Настройка доступных ролей

Добавим в список второго пользователя, дадим ему имя Директор, на закладке Прочие установим среди доступных ролей роль Сотрудник. В итоге окно Пользователи примет такой вид, рис. 1.24.

Список пользователей

Рис. 1.24. Список пользователей

Теперь внесем в нашу конфигурацию еще одно изменение. Добавим в ветвь Справочники новый справочник, назовем его Сотрудники (реквизит Имя на вкладке Основные) и добавим во все подсистемы, рис. 1.25.

Новый справочник, добавленный во все подсистемы

Рис. 1.25. Новый справочник, добавленный во все подсистемы

Проверим результаты нашей работы в режиме 1С:Предприятие. После запуска конфигурации появится окно выбора пользователя, рис. 1.26.

Окно выбора пользователя

Рис. 1.26. Окно выбора пользователя

Выбрав в списке пользователей пользователя Администратора отметим, что панель разделов в его командном интерфейсе имеет закладки для каждой из подсистем. Выбрав пользователя Директор, можно заметить, что его панель разделов не содержит раздела Администрирование.

Выводы

В этой лекции мы рассмотрели особенности установки 1С:Предприятие 8.2. – теперь на одном компьютере могут существовать различные версии системы, всеми ими можно пользоваться. Так же мы рассмотрели конвертацию информационных баз, разработанных для 1С:Предприятие 8.1., в формат, подходящий для работы в 1С:Предприятие 8.2. Мы ознакомились с процессом создания новой информационной базы, приступили к разработке прикладного решения, создав подсистемы, которые являются основой командного интерфейса, и настроив видимость разделов интерфейса по ролям для различных пользователей, воспользовавшись объектами Роль и Пользователь.

< Лекция 1 || Лекция 2: 12345 || Лекция 3 >
Лариса Дятчина
Лариса Дятчина

Код 

&НаКлиенте

Процедура ОсновноеКонтактноеЛицоПриИзменении(Элемент)

Если НЕ ПроверитьЗаполнениеРеквизита() Тогда

 Сообщить("Выбранное контактное лицо, "+Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента.");

КонецЕсли;

КонецПроцедуры

 

&НаСервере

Функция ПроверитьЗаполнениеРеквизита()

 Возврат (Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);  

КонецФункции

&НаСервере

Процедура УстановитьНомерПредставителя()

 

 Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения;

КонецПроцедуры

При проверке выдает ошибку:

{Справочник.Контрагенты.Форма.ФормаСписка.Форма(12,11)}: Переменная не определена (Объект)
 Возврат (<<?>>Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);   (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,2)}: Переменная не определена (Объект)
 <<?>>Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,32)}: Переменная не определена (Объект)
 Объект.ТелефонКонтактногоЛица=<<?>>Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(6,41)}: Переменная не определена (Объект)
 Сообщить("Выбранное контактное лицо, "+<<?>>Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента."); (Проверка: Тонкий клиент)

 

работаю на версии 1С:Предприятие 8.3 (8.3.10.2650)

максим матасов
максим матасов
Леонид Альбрехт
Леонид Альбрехт
Россия, Екатеринбург, 10, 2004
Оксана Максимова
Оксана Максимова
Россия, Екатеринбург, Уральский государственный университет им. А. М. Горького, 2013