Опубликован: 06.12.2011 | Уровень: для всех | Доступ: платный
Лекция 2:

Начало разработки

< Лекция 1 || Лекция 2: 12345 || Лекция 3 >

Рабочий стол нужен для ускорения доступа пользователя к наиболее часто используемым объектам системы. Это – одна из закладок командного интерфейса, которая появляется первой при открытии конфигурации в пользовательском режиме.

Наша подсистема видна в верхней части окна программы, в так называемой панели разделов. Она снабжена стандартным рисунком, назначаемым автоматически, подпись соответствует синониму. Щелчок по вкладке "Бухгалтерский учет" приведет нас к командам по работе с объектами конфигурации, которые включены в эту подсистему.

Здесь хочется обратить ваше внимание на кнопку Главное меню. Она открывает меню, содержащее стандартные для Windows-программ команды, рис. 1.14.

Главное меню в режиме 1С:Предприятие

Рис. 1.14. Главное меню в режиме 1С:Предприятие

В сравнении с 1С:Предприятие 8.1. в составе разделов этого меню многое поменялось (в особенности это касается разделов Вид, Сервис). В частности, обратите внимание на команду Главное меню > Все функции. Эта команда, рис. 1.15., открывает доступ к дереву объектов конфигурации, позволяет использовать некоторые стандартные команды.

Окно Все функции

Рис. 1.15. Окно Все функции

Особенно это окно полезно при разработке и отладке конфигурации – для быстрого поиска необходимых объектов без использования основного пользовательского интерфейса, для выполнения административных функций (таких, как удаление помеченных объектов, просмотр журнала регистрации). В законченной конфигурации есть смысл создать отдельную подсистему, которая будет содержать набор команд для вызова административных функций.

Вернемся в Конфигуратор, добавим к списку подсистем, которые следует создать, еще одну:

Администрирование

Теперь создадим полный набор подсистем, рис. 1.16.

Набор подсистем конфигурации

Рис. 1.16. Набор подсистем конфигурации

Снова откроем конфигурацию в режиме 1С:Предприятие, рис. 1.17.

Панель разделов после добавления подсистем

Рис. 1.17. Панель разделов после добавления подсистем

Логично было бы расположить разделы нашего прикладного решения таким образом, чтобы раздел Администрирование оказался в правой части панели. Обычно наиболее часто используемые команды располагают левее и выше других. Можно заметить, что порядок расположения разделов не соответствует порядку расположения объектов Подсистема в дереве конфигурации (обратитесь к двум предыдущим рисункам для того, чтобы это увидеть). Для того чтобы изменить порядок следования подсистем в панели разделов нужно воспользоваться командой контекстного меню корневого объекта дерева конфигурации Открыть командный интерфейс конфигурации, рис. 1.18.

Открыть командный интерфейс конфигурации

Рис. 1.18. Открыть командный интерфейс конфигурации

В появившемся окне мы можем управлять порядком следования подсистем на панели разделов и их видимостью. Еще одной полезной возможностью настройки видимости подсистем является видимость по ролям. С помощью этого механизма можно конструировать интерфейсы для отдельных ролей, которые можно назначать пользователям, формируя, таким образом, рабочую среду, которая не содержит ничего лишнего. Настроим порядок следования подсистем с помощью кнопок Переместить вверх и Переместить вниз так, чтобы они приняли вид, представленный на рисунке 1.19.

Настройка командного интерфейса

Рис. 1.19. Настройка командного интерфейса

После нажатия на кнопку ОК и запуска конфигурации в пользовательском режиме, внесенные изменения можно будет наблюдать на панели разделов.

Рассмотрим теперь настройку видимости разделов по ролям.

< Лекция 1 || Лекция 2: 12345 || Лекция 3 >
Лариса Дятчина
Лариса Дятчина

Код 

&НаКлиенте

Процедура ОсновноеКонтактноеЛицоПриИзменении(Элемент)

Если НЕ ПроверитьЗаполнениеРеквизита() Тогда

 Сообщить("Выбранное контактное лицо, "+Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента.");

КонецЕсли;

КонецПроцедуры

 

&НаСервере

Функция ПроверитьЗаполнениеРеквизита()

 Возврат (Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);  

КонецФункции

&НаСервере

Процедура УстановитьНомерПредставителя()

 

 Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения;

КонецПроцедуры

При проверке выдает ошибку:

{Справочник.Контрагенты.Форма.ФормаСписка.Форма(12,11)}: Переменная не определена (Объект)
 Возврат (<<?>>Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);   (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,2)}: Переменная не определена (Объект)
 <<?>>Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,32)}: Переменная не определена (Объект)
 Объект.ТелефонКонтактногоЛица=<<?>>Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(6,41)}: Переменная не определена (Объект)
 Сообщить("Выбранное контактное лицо, "+<<?>>Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента."); (Проверка: Тонкий клиент)

 

работаю на версии 1С:Предприятие 8.3 (8.3.10.2650)

максим матасов
максим матасов
Леонид Альбрехт
Леонид Альбрехт
Россия, Екатеринбург, 10, 2004
Оксана Максимова
Оксана Максимова
Россия, Екатеринбург, Уральский государственный университет им. А. М. Горького, 2013