Опубликован: 06.12.2011 | Уровень: для всех | Доступ: платный
Лекция 2:

Начало разработки

< Лекция 1 || Лекция 2: 12345 || Лекция 3 >

Создание новой информационной базы

Откроем окно запуска 1С:Предприятие, создадим новую пустую информационную базу. Для этого нажмем на кнопку Добавить, в появившемся окне выберем Создание новой информационной базы, в следующем окне, рис. 1.9., выберем вариант создания информационной базы без конфигурации.

Создание информационной базы без конфигурации

Рис. 1.9. Создание информационной базы без конфигурации

Дадим информационной базе имя Салон, управляемое приложение, зададим в качестве папки информационной базы C:\Salon2, остальные параметры оставим по умолчанию.

После того, как база будет создана, откроем ее в Конфигураторе и, для того, чтобы открыть дерево конфигурации, выполним команду Конфигурация > Открыть конфигурацию. Вызовем контекстное меню корневого элемента Конфигурация, выберем в нем пункт Свойства, рис. 1.10.

Свойства новой информационной базы

увеличить изображение
Рис. 1.10. Свойства новой информационной базы

Обратите внимание на то, что свойство Основной режим запуска установлено в значение Управляемое приложение, в нижней части окна свойств расположено свойство Режим совместимости, которое установлено в значение Не использовать. В данном случае оно может принимать значения Версия 8.1. и Версия 8.2.13.

В качестве имени конфигурации введем СалонКрасоты, поле Синоним будет автоматически заполнено текстом Салон красоты.

Можно заметить, что изменились изображения интерфейсных элементов в Конфигураторе. Все говорит нам о том, что сейчас мы занимаемся разработкой конфигурации в режиме управляемого приложения. Среди нововведений платформы 8.2. можно отметить изменение состава объектов конфигурации. В частности, появились следующие новые объекты:

Общие реквизиты: здесь содержатся реквизиты, которые могут использоваться во многих объектах конфигурации. Например, если вы планируете добавить в документы своей конфигурации одинаковый реквизит, содержащий наименование организации, от имени которой составлен документ, это вполне логично реализовать с помощью общего реквизита. Кроме того, общие реквизиты используются в механизме разделения данных.

Функциональные опции: их используют для того, чтобы описывать возможности, которые можно включать и отключать в процессе эксплуатации системы. Функциональные опции могут влиять на командный интерфейс, например, скрывая или отображая некоторые группы команд, а так же – на алгоритмы, написанные на встроенном языке.

Параметры функциональных опций: Содержит параметры, влияющие на функциональные опции

Хранилища настроек: Используется для сохранения и загрузки настроек.

Общие команды: Позволяет создавать команды, которые можно использовать в других объектах конфигурации, вызывая их, например, с помощью кнопок на формах.

Группы команд: Позволяет создавать группы для объединения команд

Элементы стиля: Позволяет создавать элементы стиля, такие, как цвет, шрифт, рамка, для организации единообразного оформления других объектов.

Внешние источники данных: эти объекты используются для получения информации из внешних источников и последующего использования ее в системе, в частности, в качестве источников данных для запросов, в качестве типов реквизитов информационной базы и так далее.

Теперь в дереве конфигурации нет следующих объектов:

Интерфейсы

Стили

Кроме того, некоторые объекты, в частности, это касается подсистем, теперь используются по-другому. Начнем разработку обновленной конфигурации с создания подсистем.

Подсистемы – основа командного интерфейса управляемого приложения

Ранее, когда понятия командного интерфейса не существовало, подсистемы при разработке прикладных решений для 1С:Предприятие, играли вспомогательную роль. В сущности, они были нужны лишь разработчику, помогая ему структурировать конфигурацию для своих целей и автоматизировать некоторые операции. С приходом командного интерфейса подсистемы приобрели новую роль – именно на их основе строится интерфейс приложений. Поэтому с них мы и начнем работу по созданию нашей конфигурации. Так как мы будем основываться на ранее разработанной конфигурации, предназначенной для 1С:Предприятие 8.1., вспомним, какие подсистемы она содержала. Для этого можно открыть нашу старую конфигурацию и посмотреть ветвь дерева конфигурации Общие > Подсистемы, рис. 1.11. Точно так же можно будет обращаться к старой конфигурации в дальнейшем.

Подсистемы в старой информационной базе

Рис. 1.11. Подсистемы в старой информационной базе

Итак, мы видим, что в нашей старой конфигурации были созданы подсистемы:

  • Бухгалтерский учет
  • Оперативный учет материалов
  • Учет работы мастеров
  • Расчет заработной платы

Создадим те же подсистемы в новой конфигурации. Порядок создания новых объектов конфигурации выглядит так же, как он выглядел ранее. Для создания новой подсистемы нужно перейти в ветвь дерева конфигурации Общие > Подсистемы, после чего либо выбрать команду Добавить из контекстного меню ветви Подсистемы, либо выделить эту ветвь и нажать клавишу Ins на клавиатуре, либо воспользоваться кнопкой Добавить из командной панели дерева конфигурации. После этого появится окно редактирования объекта конфигурации, приведенное на рис. 1.12.

Окно редактирования объекта

Рис. 1.12. Окно редактирования объекта

Здесь можно либо перемещаться по вкладкам окна в произвольном порядке, либо, используя кнопку Далее, перемещаться по ним последовательно.

Зададим следующие параметры для нашей новой подсистемы:

Имя: БухгалтерскийУчет

Синоним: Бухгалтерский учет

Синоним генерируется автоматически на основе имени, при необходимости его можно отредактировать вручную.

Поле Картинка можно использовать для того, чтобы задать подсистеме заранее созданную картинку. Это позволяет сделать интерфейс пользователя более удобным.

После того, как подсистема создана, посмотрим, на что будет похожа разрабатываемая конфигурация в режиме 1С:Предприятие. Запустим ее в этом режиме из Конфигуратора, воспользовавшись комбинацией клавиш Ctrl+F5, соответствующей командой меню (Сервис > 1С:Предприятие), или кнопкой на панели инструментов Конфигурация.

То, что мы увидим после запуска конфигурации, разительно отличается от того, что мы привыкли видеть, рис. 1.13.

Разрабатываемая конфигурация в режиме 1С:Предприятие

Рис. 1.13. Разрабатываемая конфигурация в режиме 1С:Предприятие
< Лекция 1 || Лекция 2: 12345 || Лекция 3 >
Лариса Дятчина
Лариса Дятчина

Код 

&НаКлиенте

Процедура ОсновноеКонтактноеЛицоПриИзменении(Элемент)

Если НЕ ПроверитьЗаполнениеРеквизита() Тогда

 Сообщить("Выбранное контактное лицо, "+Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента.");

КонецЕсли;

КонецПроцедуры

 

&НаСервере

Функция ПроверитьЗаполнениеРеквизита()

 Возврат (Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);  

КонецФункции

&НаСервере

Процедура УстановитьНомерПредставителя()

 

 Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения;

КонецПроцедуры

При проверке выдает ошибку:

{Справочник.Контрагенты.Форма.ФормаСписка.Форма(12,11)}: Переменная не определена (Объект)
 Возврат (<<?>>Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);   (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,2)}: Переменная не определена (Объект)
 <<?>>Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,32)}: Переменная не определена (Объект)
 Объект.ТелефонКонтактногоЛица=<<?>>Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(6,41)}: Переменная не определена (Объект)
 Сообщить("Выбранное контактное лицо, "+<<?>>Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента."); (Проверка: Тонкий клиент)

 

работаю на версии 1С:Предприятие 8.3 (8.3.10.2650)

максим матасов
максим матасов
Леонид Альбрехт
Леонид Альбрехт
Россия, Екатеринбург, 10, 2004
Оксана Максимова
Оксана Максимова
Россия, Екатеринбург, Уральский государственный университет им. А. М. Горького, 2013