Рейтинг выпускников | 

Инна Фёдорова
Инна Фёдорова || рейтинг: 11.00 (общий рейтинг: 11.00)
Андрей Шишмарев
Андрей Шишмарев || рейтинг: 11.00 (общий рейтинг: 74.50)
Россия, Курск, Курский государственный технический университет, 1998
Темы:
предложить дружбу
Максим Чернов
Максим Чернов || рейтинг: 11.00 (общий рейтинг: 20.30)
Павел Гаврилов
Павел Гаврилов || рейтинг: 11.00 (общий рейтинг: 21.00)
Россия, Волгоград, ВолгГТУ, 2011
Темы:
предложить дружбу
Федор Калуженов
Федор Калуженов || рейтинг: 11.00 (общий рейтинг: 33.30)
Виктория Тысячная
Виктория Тысячная || рейтинг: 11.00 (общий рейтинг: 20.90)
Лариса Дятчина
Лариса Дятчина

Код 

&НаКлиенте

Процедура ОсновноеКонтактноеЛицоПриИзменении(Элемент)

Если НЕ ПроверитьЗаполнениеРеквизита() Тогда

 Сообщить("Выбранное контактное лицо, "+Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента.");

КонецЕсли;

КонецПроцедуры

 

&НаСервере

Функция ПроверитьЗаполнениеРеквизита()

 Возврат (Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);  

КонецФункции

&НаСервере

Процедура УстановитьНомерПредставителя()

 

 Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения;

КонецПроцедуры

При проверке выдает ошибку:

{Справочник.Контрагенты.Форма.ФормаСписка.Форма(12,11)}: Переменная не определена (Объект)
 Возврат (<<?>>Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);   (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,2)}: Переменная не определена (Объект)
 <<?>>Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,32)}: Переменная не определена (Объект)
 Объект.ТелефонКонтактногоЛица=<<?>>Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(6,41)}: Переменная не определена (Объект)
 Сообщить("Выбранное контактное лицо, "+<<?>>Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента."); (Проверка: Тонкий клиент)

 

работаю на версии 1С:Предприятие 8.3 (8.3.10.2650)

максим матасов
максим матасов
Сергей Кабанов
Сергей Кабанов
Россия, Москва, МИРЭА, 2000
Александр Сторчак
Александр Сторчак
Украина, Донецк, КА «Шаг» (ВМУРоЛ «Украина»)