Вопросы

Лариса Дятчина
Почему не работает код

Код 

&НаКлиенте

Процедура ОсновноеКонтактноеЛицоПриИзменении(Элемент)

Если НЕ ПроверитьЗаполнениеРеквизита() Тогда

 Сообщить("Выбранное контактное лицо, "+Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента.");

КонецЕсли;

КонецПроцедуры

 

&НаСервере

Функция ПроверитьЗаполнениеРеквизита()

 Возврат (Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);  

КонецФункции

&НаСервере

Процедура УстановитьНомерПредставителя()

 

 Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения;

КонецПроцедуры

При проверке выдает ошибку:

{Справочник.Контрагенты.Форма.ФормаСписка.Форма(12,11)}: Переменная не определена (Объект)
 Возврат (<<?>>Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);   (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,2)}: Переменная не определена (Объект)
 <<?>>Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,32)}: Переменная не определена (Объект)
 Объект.ТелефонКонтактногоЛица=<<?>>Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(6,41)}: Переменная не определена (Объект)
 Сообщить("Выбранное контактное лицо, "+<<?>>Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента."); (Проверка: Тонкий клиент)

 

работаю на версии 1С:Предприятие 8.3 (8.3.10.2650)

Лариса Дятчина
Лариса Дятчина 13 февраля в 22:44

Вопрос снимается, пропустила (), исправила, все работает. Нашла ответ в просмотренном видео. Спасибо.

Андрей Стариков
Какая версия 1С используется в курсе?

При использовании версии 1С:Предприятие 8.2, учебная версия (8.2.17.169)  при вводе примера лекция 6 стр. 3 возникает ошибка

{Обработка.РаботаСоСправочниками.Форма.Форма.Форма(67,1)}: Неопознанный оператор
<<?>>&НаКлиенте (Проверка: Сервер)
{Обработка.РаботаСоСправочниками.Форма.Форма.Форма(1,1)}: Обнаружено логическое завершение исходного текста модуля (Проверка: Сервер)
{Обработка.РаботаСоСправочниками.Форма.Форма.Форма(67,1)}: Неопознанный оператор
<<?>>&НаКлиенте (Проверка: Тонкий клиент)
{Обработка.РаботаСоСправочниками.Форма.Форма.Форма(1,1)}: Обнаружено логическое завершение исходного текста модуля (Проверка: Тонкий клиент)

Вводимый код:

&НаКлиенте
Процедура НайтиЗаданныйЭлемент(Команда)
        НайтиЗаданныйЭлементНаСервере();
КонецПроцедуры


Процедура НайтиЗаданныйЭлементНаСервере()
   СсылкаНаЭлемент=Справочники[ИмяСправочника].НайтиПоНаименованию(НаименованиеЭлемента);
   Если СсылкаНаЭлемент=Справочники[ИмяСправочника].ПустаяСсылка()
        Тогда
        Сообщить("В справочнике "+ИмяСправочника+" нет элемента "+НаименованиеЭлемента);
        Иначе
        Элемент=СсылкаНаЭлемент.ПолучитьОбъект();
        СтароеНаименование=Элемент.Наименование;
        Элемент.Наименование=ВРег(Элемент.Наименование);
        Элемент.Записать();
        Сообщить("Элемент справочника "+ИмяСправочника+"с кодом "+Элемент.Код+" найден, наименование изменено с "+СтароеНаименование+" на "+Элемент.Наименование);
   КонецЕсли;
КонецПроцедуры
 

 

Валерий Евдокимов
Валерий Евдокимов 6 августа 2015 в 14:48

Код верный. Скорее всего надо в своиствах комады "НайтиЗаданныйЭлемент" указать действие "НайтиЗаданныйЭлемент".

Иван Иванов
Иван Иванов 7 апреля 2016 в 07:40

Мне удалось повторить такую ошибку только после добавления точки с запятой (;) после предыдущего оператора КонецПроцедуры

Владимир Крюков
Владимир Крюков
Казахстан
Евгений Окладников
Евгений Окладников
Россия