Опубликован: 06.12.2011 | Доступ: свободный | Студентов: 5451 / 1553 | Оценка: 4.55 / 4.38 | Длительность: 10:27:00
  • Все
  • |
  • A
  • B
  • C
  • D
  • E
  • F
  • G
  • H
  • I
  • J
  • K
  • L
  • M
  • N
  • O
  • P
  • Q
  • R
  • S
  • T
  • U
  • V
  • W
  • X
  • Y
  • Z
bin
Лекция: 1 стр. 1
Предложите свое определение
excel
Лекция: 5 стр. 4
Предложите свое определение
администратор
Лекция: 1 стр. 4
Предложите свое определение
администрирование
Лекция: 1 стр. 3
Предложите свое определение
анализ
Лекция: 7 стр. 2, 8 стр. 1
Предложите свое определение
базы данных
Лекция: 4 стр. 2
Предложите свое определение
буфер
Лекция: 7 стр. 2
Предложите свое определение
бухгалтерский учет
Лекция: 1 стр. 2
Предложите свое определение
ветвь
Предложите свое определение
виртуальная таблица
Лекция: 7 стр. 3, 8 стр. 6
Предложите свое определение
время выполнения
Лекция: 2 стр. 4
Предложите свое определение
выборка
Лекция: 5 стр. 5
Предложите свое определение
вывод
Предложите свое определение
выражение
Лекция: 4 стр. 2
Предложите свое определение
выручка
Лекция: 8 стр. 1, 8 стр. 2
Предложите свое определение
группа
Лекция: 2 стр. 1, 4 стр. 2
Предложите свое определение
двойной щелчок
Предложите свое определение
дерево конфигурации
Предложите свое определение
директива
Предложите свое определение
дистрибутив
Лекция: 1 стр. 1
Предложите свое определение
Лариса Дятчина
Лариса Дятчина

Код 

&НаКлиенте

Процедура ОсновноеКонтактноеЛицоПриИзменении(Элемент)

Если НЕ ПроверитьЗаполнениеРеквизита() Тогда

 Сообщить("Выбранное контактное лицо, "+Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента.");

КонецЕсли;

КонецПроцедуры

 

&НаСервере

Функция ПроверитьЗаполнениеРеквизита()

 Возврат (Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);  

КонецФункции

&НаСервере

Процедура УстановитьНомерПредставителя()

 

 Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения;

КонецПроцедуры

При проверке выдает ошибку:

{Справочник.Контрагенты.Форма.ФормаСписка.Форма(12,11)}: Переменная не определена (Объект)
 Возврат (<<?>>Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);   (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,2)}: Переменная не определена (Объект)
 <<?>>Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,32)}: Переменная не определена (Объект)
 Объект.ТелефонКонтактногоЛица=<<?>>Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаСписка.Форма(6,41)}: Переменная не определена (Объект)
 Сообщить("Выбранное контактное лицо, "+<<?>>Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента."); (Проверка: Тонкий клиент)

 

работаю на версии 1С:Предприятие 8.3 (8.3.10.2650)

максим матасов
максим матасов
Артур Гибадуллин
Артур Гибадуллин
Россия, г. Нижневартовск